[SOLVED] Everloop leds problem

My problem:
I need to control the everloop leds in c++ through matrix hal. I have build and run the supplied demos (everloop, compass, arc) and got weird results.
For example when running the compass demo, more than two leds are lighted on and blinking with strange colors. The everloop seems to be unstable and not fully fonctionnal. Can it be a wrong setup ? A hardware failure ? Thanks for any help or advice.

My hardware setup:

  • brand new raspberry pi 3 and matrix board
  • raspberry pi cam 3 v2.11
  • 5V 3A DC power

Software setup:

  • latest raspbian jessie
  • i have only installed the minimum required packages as explained in “getting started” documentation (matrix-creator-init, libzmq3-dev, etc…)
  • “matrix hal” cloned from matrix-io github one week ago

I’ve just tried with the usb power cable plugged on a desktop pc:
The everloop demo is now working well, but a power warning icon is displayed on the linux desktop top left corner.

With a 5v 1A DC power:
All is working fine (everloop demo ok,and no more power warning icon).

So it’s obviously a problem related to powering.

Hey @Benoit,

Thanks for the information, as of right now the we recommend the power supply to be a 5V 2A (low ripple) power supply for typical use. It can operate on 5V 1A power supplies, some people have had issues though (might be quality of power supply at that point). Let us know if you need any additional assistance with this!

I have a top-quality 3A power supply.
The LEDs are very bright but the colors are all wrong.
Interestingly, when the program is terminated, the LEDs keep changing althought more slowly.

Hi @rkeithbeal,

Can you share what specific power supply are you using? Maybe a photo of the specs label ?. You can try use other power supplies or just simply use the USB from you computer and test again the LEDs.

Please share your results.


Also here is a link of one power supply that we have tested.

At your suggestion, I hooked-up the Pi to a bench supply and it works.
The power supply claims to be 5.1v @ 3A but the meter says it is drawing a little over 2/3 of that.
Thanks for the reply.

Can you suggest a compact PS?

Hi @rkeithbeal,

I am not sure what do you mean by “compact”, smaller than the CanaKit suggested before?
As a general specs for the PS use :

Hope this help.