[Solved] Failed installation of matrixio-malos because broken packages

Hey

I did not find the same problem with the search function here in the forum, therefore my question/ problem is:

Setup:

  • RaspberryPi 3. Version B V1.2
  • Matrix Voice connected
  • USB Power
  • PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
  • VERSION_ID=“9”
  • VERSION=“9 (stretch)”

I followed the instrcution on: https://matrix-io.github.io/matrix-documentation/matrix-core/getting-started/core-installation/

After: sudo apt-get install matrixio-malos, I’ ve recived the following error message:

fail

Therefore the next step for installation process of ZeroMQ failed as well.

echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" >> /etc/apt/sources.list

zeroMQ

–> Reboot does not helped.

Many thanks.
Marc

Hi @IFE. Can you try reinstalling the packages? I just tested the installation on a new Raspbian Stretch Lite image and I couldn’t reproduce your errors. If you’re still experiencing issues, starting from a fresh image should work. Let us know if you have any more questions.

Hi @Carlos, I have reinstalled the complete Raspbian and I have the same problem:

sudo apt-get install matrixio-malos

Result:

I’ve tried a third time with a fresh Raspberry Pi:

  1. curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
    
  2. echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
    

Then I’ ve skipped:

  1. sudo apt-get update
  2. sudo apt-get upgrade

The result was:
third

Then I thought I will test if zeromq installtion will work:

echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" >> /etc/apt/sources.list

The result was:
denied

You see a lot of “permission denide” and “unable to locate” stuff, but I have no idea why.

I tried all this and it worked. The only thing that i had to do differently was the line:

echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" >> /etc/apt/sources.list

I was getting the same error

So, I used tee instead:

echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" | sudo tee /etc/apt/sources.list

Thanks for letting us know. This will be fixed in the next update in the documentation.

Let me know if it work after this change.

There has been something odd going on with the raspbian repos for the past couple days, possibly due to an update they are pushing. I got essentially this same error on a fresh reinstall when trying to add matrixio-kernel-modules - it seems dkms is no longer in the main repos at all (which is rather odd…) so anything that depends on them can’t install.

I was able to install malos, though, so I haven’t seen this exact issue.

I’ll play around with this a bit more later when I have some time, I’m still not sure what has changed in the distro repos to cause these problems.

Ah I was wrong. The modified ‘tee’ command you used (which I then copied) overwrites the main apt sources file so then the main repo isn’t queried… I would instead recommend creating a new file, as most other apt providers seem to do -

echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" | sudo tee /etc/apt/sources.list.d/zeromq.list

After fixing that, all the packages seemed to install as expected for me, so I’m not so helpful with this particular issue.

1 Like

Hey @IFE, Are you still having those problems?

Hello @giblet37, thanks for the recommendation. It has been updated in the documentation.

Sorry, I was out of buisness for a couple of days. Thanks for your help.

To be clear, there are TWO problems:

PROBLEM 1 (UNSOLVED): Install the the MATRIX CORE packages
Work flow:

  1. curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
  2. echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
  3. SKIP sudo apt-get update AND sudo apt-get upgrade
  4. sudo apt-get install matrixio-malos

Result was, Matrixio Malos could not be installed becasue of “unable to locate package matrixio-malos”:

PROBLEM 2 (SOLVED?): Install ZeroMQ

permission denied failure when using:

  • echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" >> /etc/apt/sources.list

problem “permission denied” is solved when using instead:

  • echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" | sudo tee /etc/apt/sources.list.d/zeromq.list
    

Result was:
zeromq

It looks, that the new code for installation of ZeroMQ would help (permission denied problem is gone), but I am not sure if it has been installed correctly.

Can you try without skipping the sudo apt-get update? Why did you skip it?

Without skipping, the result was: “Unable to correct problems, you have held broken packages”

With skipping (I thought maybe there is something wrong with the update process) the result was: “Unable to locate package matrixio-malos”

–> There was a difference with and without skipping. But both ways ended up in an error:grin:

I have gone through all of the steps with a fresh new Raspberry Pi and it is important to skip the step: sudo apt-get upgrade because if I do the upgrade step followed by sudo apt-get install matrixio-malos I receive the error message: “unable to correct problems, you have held broken packages”

Therefore, what I have done with a fresh Raspberry Pi are following steps and at the end it still does not work:

  1. curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
  2. echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
  3. sudo apt-get update
  4. sudo apt-get install matrixio-malos
  5. sudo reboot
  6. echo "deb http://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/ ./" | sudo tee /etc/apt/sources.list.d/zeromq.list
  7. wget https://download.opensuse.org/repositories/network:/messaging:/zeromq:/release-stable/Debian_9.0/Release.key -O- | sudo apt-key add
  8. sudo apt-get update
  9. sudo reboot
  10. cd ~/
  11. mkdir python-matrix-core-app
  12. cd python-matrix-core-app
  13. wget "https://github.com/matrix-io/matrix-creator-malos/blob/master/src/python_test/Pipfile" -O Pipfile
  14. wget "https://github.com/matrix-io/matrix-creator-malos/blob/master/src/python_test/Pipfile.lock" -O Pipfile.lock
  15. wget "https://raw.githubusercontent.com/matrix-io/matrix-creator-malos/master/src/python_test/requirements.txt" -O requirements.txt
  16. wget "https://raw.githubusercontent.com/matrix-io/matrix-creator-malos/master/src/python_test/utils.py" -O utils.py
    17.sudo apt-get install build-essential python-dev
  17. sudo apt-get install python3-pip
  18. pip3 install -r requirements.txt
  19. Creating app.py
  20. python app.py

Result was:

error

Can you now try a sudo apt-get upgrade and test the python app again?

Unfotunately, sudo apt-get upgrade does not worked

Any other ideas?

@IFE you’re using python 2, but you have the dependancies installed for python 3. Try running the script with:

python3 app.py

Oh my …that is the solution. It would be better in the future to think about code instead of simple copy and paste it :wink: Thanks for your help!

I would reccomend to make the code clear in the documentation https://matrix-io.github.io/matrix-documentation/matrix-core/getting-started/python-installation/
–> Add python3 app.py as well

1 Like

Glad to hear everything is working for you. We’ve updated the page to include instructions on how to run a Python 2 and Python 3 file. :slightly_smiling_face:

Hi,

Setup Raspi PI3+, Matrix Voice module.

Kernel version 4.14 because of the 4.19 issue, set kernel and headers on hold.

Result of trying to install matrix-malos:
pi@assi:~ curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add - pi@assi:~ echo "deb https://apt.matrix.one/raspbian (lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list pi@assi:~ sudo apt-get update
pi@assi:~ sudo apt-get upgrade pi@assi:~ sudo apt-get install matrixio-malos
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
matrixio-malos : Hängt ab von: matrixio-protobuf soll aber nicht installiert werden
Hängt ab von: libmatrixio-malos soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Sorry for the German!
Says to me, I have broken packages.

I have tried to upgrade to 4.19…
and with 4.14 but kernel and kernel-headers set to unhold…
…I did it with and without sudo apt-get upgrade.

Always with the same result.

Thx for helping me here!

Cheers