[Solved] Google Assist compile error

Hi there,

as i read that google assist is running i want give it a try.

But when starting compiling it fails right after seconds with following error.

make -C /lib/modules/4.14.30-v7+/build M=/home/pi/matrixio-kernel-modules modules
make[1]: Entering directory '/usr/src/linux-headers-4.14.30-v7+'
  CC [M]  /home/pi/matrixio-kernel-modules/matrixio-pcm.o
/home/pi/matrixio-kernel-modules/matrixio-pcm.c:217:5: error: unknown field ‘copy’ specified in initializer
     .copy = matrixio_pcm_copy,
/home/pi/matrixio-kernel-modules/matrixio-pcm.c:217:13: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
     .copy = matrixio_pcm_copy,
/home/pi/matrixio-kernel-modules/matrixio-pcm.c:217:13: note: (near initialization for ‘matrixio_pcm_ops.get_time_info’)
cc1: some warnings being treated as errors
scripts/Makefile.build:334: recipe for target '/home/pi/matrixio-kernel-modules/matrixio-pcm.o' failed
make[2]: *** [/home/pi/matrixio-kernel-modules/matrixio-pcm.o] Error 1
Makefile:1519: recipe for target '_module_/home/pi/matrixio-kernel-modules' failed
make[1]: *** [_module_/home/pi/matrixio-kernel-modules] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.14.30-v7+'
Makefile:18: recipe for target 'all' failed
make: *** [all] Error 2

Did i miss something?

It is a fresh setup and i followed this guide:



Im having the exact same issue - yet a week ago the install worked for some reason - im assuming they have made code changes which have broken it - i guess we just wait and see now for it to be fixed…

Hi @I-Zen-Robotics and @TuxTux,

Thanks for reporting this issue. The implementation was not compatible with the latest kernel version 4.14.30-v7+. We just did the update and should be good to go.
Please, update your matrixio-kernel-modules repo and buld it again to test.

cd matrixio-kernel-modules/
git pull
make && make install


1 Like

Hi @yoelrc88,
thank you for fixing this issue. Google Assistant is working! Hurray!!!


1 Like

sadly mine isnt fixed - fresh install and following the guide reaches here??

pi@raspberrypi:~ $ sudo apt-get install matrixio-creator-init
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
matrixio-creator-init : Depends: libmatrixio-creator-hal but it is not going to be installed
Depends: matrixio-xc3sprog but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@raspberrypi:~ $

further update:
it is now installing - i did just notice an update to the github since i posted the error - appears as though - cutting edge is really cutting edge currently
– ok onward and hopefully upward we go

pi@raspberrypi:~ $ arecord --duration 5 --rate 16000 --format S16_LE test.wav
arecord: main:788: audio open error: No such file or directory

same place as i have been before - and if i do manage to recor4d anything it is all just a hammering noise — this is getting very very frustrating - and im beginnning to think i have a faulty board — trying to get ANYTHING working fully on it has proven unsuccesful to date – over a week of trying :frowning: :thinking::face_with_raised_eyebrow::frowning_face::disappointed:

Hey @I-Zen-Robotics,

Thanks for keep trying. Can you open a new post so we can close this one?
Let’s try to troubleshoot your issues in the new post. If you want to test the mics you can try the guide Hardware Test: Microphones 🎤 and let us know the result in the new post .

Thank you,


Hi @I-Zen-Robotics,

i got the same error in the beginning.
I used the lite raspbian image from 03.2018

After that I did a update and upgrade.

Then I add the matrix repo and installed the matrix stuff followed by the kernel headers. After that was completed I cloned the repository and copied the arsoundrc file. Now I did a reboot and trying to do the record and play .

If this is not working for you I can make a image for you and upload it.

Let me know if you need it or not.

1 Like

Hey mate - if you could up an image for me that would be awesome - at leasrt then i will get some idea of whether or not its hardware problems or not - cheers

Great, will do it tomorrow. Have a drink :tumbler_glass: @ the moment after barbecue;-) in Germany is evening at the moment. :wink:

Will tell you tomorrow where to download.

1 Like

no worries mate - i appreciate it - haha enjoy your drink :hamburger: :beers: :tumbler_glass:- i look forward to it

ok - FINALLY got google assistant working - the install instructions do need to be tidied up and checked but it does work now kind of from those… ok - now to see if i can get alexa working :stuck_out_tongue:


Hey, happy to hear that, so i do not need to upload. :slight_smile:

Alexa is working the way, but if you install the alexa app on your mobile you can add skills to alexa.

Playing musik on Google Assist is not possible by the sdk and on alexa only tunein radio is working.

But all these restrictions are by the sdk’s and not by the matrix creator or voice.

Have fun :slight_smile: