[SOLVED] Malos command error

hello there,

I have an issue with MALOS.
after i run the examples successfully and try $ malos command again, i get the following error:

"
you can query specific driver info using port 20012.
terminate called after throwing an instance of 'zqm:: error_t’
what (): Address already in use
Aborted

"

what am i missing? things still work fine, but i do not get the information from malos

Regards,
Rabih

Hi @rmaalouf,

That error that you got is beacause MALOS is already running . You can use top commando to check if its running or simply kill it with:
$ sudo pkill malos

you should get the following:

pi@raspberrypi:~ $ sudo malos
**************
MALOS starting
**************

You can query specific driver info using port 20012.
Registered driver IMU with port 20013.
Registered driver Humidity with port 20017.
Registered driver Everloop with port 20021.
Registered driver Pressure with port 20025.
Registered driver UV with port 20029.
Registered driver ZigbeeBulb with port 20033.
Registered driver MicArray_Alsa with port 20037.
Registered driver Lirc with port 20041.
Registered driver Servo with port 20045.
Registered driver Gpio with port 20049.

thank you.

that worked