[Solved] Matrix Creator HAL Demo Not working

With RPI3 and matrix-creator board. I have updated matrix-creator init. I have found floating point exception and one light blinking only.

Do you have detailed steps on the exact Jessie or Stretch image you started with. I’m having the same issue with Stretch but I see other posts saying Stretch (Desktop and Lite) are not yet supported. Am trying to find out what base OS image works for everyone and the exact steps used (want to use micarray_recorder only for now).

Raspbian Stretch with desktop
Image with desktop based on Debian Stretch
Version: November 2017
Release date: 2017-11-29
Kernel version: 4.9

I have tried with Desktop and Lite version (Version: November 2017, Release date: 2017-11-29, Kernel version: 4.9) and initially it was not working. But, suddenly after doing:

Add repo and key

curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo “deb https://apt.matrix.one/raspbian $(lsb_release -sc) main” | sudo tee /etc/apt/sources.list.d/matrixlabs.list

Update packages and install

sudo apt-get update
sudo apt-get upgrade

Installation

sudo apt install libmatrixio-creator-hal libmatrixio-creator-hal-dev

and a reboot, it started working. I do not know how much stable/correct it is.

Hi guys,

Stretch is supported. After an update/upgrade and HAL should work.

Please, follow the guide in the readme of the HAL repo https://github.com/matrix-io/matrix-creator-hal

Yes, now it is working.