[Solved] Matrix-creator-hal not work

Hi,
when i install matrix-creator-hal in my raspberry-pi use this link:
https://github.com/matrix-io/matrix-creator-hal/tree/v0.1.4
it can not install matrixio-creator-init, it shows that :
Unable to locate package matrixio-creator-init
I ignored this problem, i make a dir build and cmake … , make , sudo make install success ,but when i execute demos , its not work.
for example : ./mic_energy
shows: Floating point exception.
./everloop_demo
led is not work, no light.

Can anyone help me? thank you!

Same problems here. I did get the matrixio-creator-init package though. But I get the same floating point exception on all mic-related demos. arc-demo doesn’t do anything. Everloop demo blinks only one led for a bit.

Jiong, try this before installing, might help getting the packages (found it on the HAL github):

echo "deb http://packages.matrix.one/matrix-creator/ ./" | sudo tee --append /etc/apt/sources.list;

Yes, I have the same problem. My setup was working nicely, at least all of the demos ran. But then I did a git pull to get the latest changes to the HAL. Now the creator doesn’t work at all. I believe the changes introduced by the commit “endianess coherence” are problematic.

Also not the changed library names and that most of the online docs are wrong and refer to libraries that don’t exist. I have added the packages.matrix.one/matrix-creator deb source to my sources.list

Is there a firmware upgrade that needs to be applied? my matrix-creator-init is up to date.

I had the same problem - everloop resulted in a one light randomly blinking red/green and another just blinking blue.

As stwfstwf suggested, it’s caused by s a problem in the codebase updates. I rolled back to the earlier release (https://github.com/matrix-io/matrix-creator-hal/releases/tag/0.1.2) and at least everloop, arc, mic demos work fine now.

Rolling back to before they submitted the endianness changes also works:

git reset --hard ed4ca8c36e763587df02ecb5151b200c34e19503

Hello,

Yes you are right. We are working in the debian support for stretch. Please https://github.com/matrix-io/matrix-creator-init/blob/master/blob/system.bit copy this file in /usr/share/admobilize/matrix-creator/blob/. This week you will have good news about us.

Let me know how it works.

Regards,

Kevin Patino
MATRIX Labs Team

Copying that system.bit file and rebooting did get the examples working. Thanks.

https://github.com/matrix-io/matrix-creator-init/blob/master/blob/system.bit result in page not found 404. Do you have an updated page or new steps to follow ?

Hi @kwiatks,

That response from @kevindpatino was back in October. That file name changed its name in later releases.

Stretch support has been out for a while. Please try to follow the steps in the HAL repo https://github.com/matrix-io/matrix-creator-hal.

Let us know if you need help.

Hi @yeolrc88,
I just followed steps on github https://github.com/matrix-io/matrix-creator-hal, and the issue is reproducible.
To be more detail, after I install matrix-creator-hal, and cd to ~/matrix-creator-hal/build/demos, if I run, for example, ./micarray_recorder
terminal will show: Floating point exception
same thing as ./mic_energy
and if I run ./everloop_demo, LED is not work.

Can you try to reproduce that? and what can I do to solve this?

Thanks

@GoodLife,

I just went through all steps in the readme (using a MATRIX Voice) and I could run all demos without getting this error.
My setup:

Can you share more details of your setup ?

I got what GoodLife describes.
Pi 3 model B (revision a02082). A fresh Raspbian Stretch (full) image. Matrix Voice. Installed matrix-creator-hal according to instructions (either apt or from source). No errors on install, but the hal examples don’t work, some say Floating point exception.

Also malos does not start :


MALOS starting


You can query specific driver info using port 20012.
Registered driver IMU with port 20013.
Registered driver Humidity with port 20017.
Registered driver Everloop with port 20021.
Registered driver Pressure with port 20025.
Registered driver UV with port 20029.
Floating point exception

Hello @beeguy123, Could you try with:

# Add repo and key
curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list

# Update packages and install
sudo apt-get update
sudo apt-get upgrade

sudo apt-get install matrixio-malos
sudo reboot

Let me know how the things works.

Regards,

Kevin Patino

Just ran this… on a similar setup

Raspbian 2017-11-29 and still getting a floating point exception with the mic_demo, mic_array… Additionally getting 0 on all my sensors

Hello @whilom could you run: sudo dpkg -l | grep matrixio and sudo dpkg -l | grep matrix. Just to confirm which version of the packages have you installed in your board.

Thank You

Regards,

Kevin Patino

ii libmatrixio-creator-hal:armhf 0.1.4 armhf Hardware Abstraction Layer for MATRIX.
ii libmatrixio-creator-hal-dev 0.1.4 armhf Hardware Abstraction Layer for MATRIX (headers)
ii matrix-creator-init 0.3.1 armhf Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.
ii matrix-creator-openocd 1.0.0.001-1.3 armhf Open on-chip JTAG debug solution for ARM and MIPS systems
rc matrixio-creator-init 0.4.0 armhf Install scripts that can program the MATRIX Creator FPGA and SAM3 IMU.

Hello @whilom,

Thank You for your answer we found the issue. Now you have installed outdated packages.

You need to run:

sudo apt-get remove --purge  matrix-creator-init  matrix-creator-openocd 

Also, you need to remove the old repository from your apt-list, you need to erase "deb http://packages.matrix.one/matrix-creator/ ./" in your /etc/apt/sources.list. You need to use super user permission to delete this line.

Please keep in mind that the new repository is:

# Add repo and key
curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list

Then run:

sudo apt-get update
sudo apt-get upgrade

Thank You, I’m looking forward to your answer and how the things are working.

Regards,

Kevin Patino

1 Like

Never mind, my problem seems to be solved. Not sure what exactly changed to fix it. Both my Voices now functioning.

1 Like

Sensors sadly all still return 0 and I’m still getting a floating point exception on the microphone.

Not sure if this is useful but I ran the firmware demo and its giving me back:
MCU ID = 0x0
MCU version = 0x0

@whilom, please show me the result of running this command:

/usr/share/matrixlabs/matrixio-devices/fpga_info 

– adc

I have the same issue. I am getting Zeros and NaN from sensors and Floating point exception from mics.
I had things working before, but I moved the devices to the lab and now I am getting these same errors.
I even tried with a fresh raspbian image and fresh matrix install. I have followed the steps in this post and:
pi@raspberrypi:~$ /usr/share/matrixlabs/matrixio-devices/fpga_info
IDENTIFY = ffffffff
VERSION = ffffffff
I think I need to reflash the FPGA, but I am not sure how to do that. Any assistance would be greatly appreciated.