[Solved] Matrix OS: cannot add device (seems it registers to admobilize but it's not pushing anything on the websocket)

Hi,

I’m running a Matrix Creator V1/2017 rev 2 on RPi3, stretch lite, everything up to date -(re)installed from scratch this morning-.

Installation of the Matrix CORE seems to be ok, all the examples are running fine.

I’ve got troubles with Matrix OS:

I’ve (re)created an account from the matrix-cli, registered a new device and put the secrets on the pi before launching matrix OS manually.

The everloop is then displaying a marvellous spinning rainbow, but I cannot reach my device either from the matrix-cli on my computer or the iOS app.

Debug ($ DEBUG=* node index.js | grep -v ‘Component]::led’) does not give me any errors and I can see the correct device_id and device_secret.

The last messages are:

  token processDeviceToken - Matrix.userId> XXXXXXX +1ms
  token processDeviceToken - Matrix.deviceRecordId> null +0ms
  stream Init Streaming Server: wss://mxss.admobilize.com/engine.io?deviceToken=YYYYYYY +6ms
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []

On my iOS app, I have a red banner showing “MXSS disconnected”.
On the matrix-cli I have a status "ok=no, last online=48 years ago"
On the dash.admobilize.com dashboard, I can see my device…, not updated since I’ve created the device with the matrix-cli.

Help :slight_smile:

It works better now, this is what I did:

I’ve launched Matrix OS without MXSS MATRIX_NOMXSS=true node index.js, then the log went to the “Matrix [o__o]” message.

Then I’ve relaunched Matrix OS normally, node index.js and voilà, it worked.
Very strange…

Last thing: I’ve got the following message “MATRIX OS can be upgraded. 0.17.0 available! 0.16.0”, but I’m using the latest version on the dev branch on https://github.com/matrix-io/matrix-os. Where can I find this 0.17 version ?