[Solved] MATRIX-OS Installation

I followed the instructions on the website but am still struggling getting it to work.

Looks like the setup should be working because,

pi@raspberrypi:~/matrix-os $ NODE_ENV=rc node index.js
Environment Selected: rc
Loading...  device
Loading...  event
Loading...  service
Not using device data from db, using MATRIX_DEVICE_ID and MATRIX_DEVICE_SECRET instead!
Starting as device: d742704ba679
Installed Apps: 
Local Apps: 
Local / Installed Δ 0
MXSS Connected: https://mxss.admobilize.com
MALOS Unavailable
=<[^\/^]>= [d742704ba679] ready
[58d481fa9a19ad2000600683]
 _  _ ____ ___ ____ _ _  _ 
 |\/| |__|  |  |__/ |  \/   [o__o]
 |  | |  |  |  |  \ | _/\_  v0.16.0
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []
hb: sen> [] svc> []

But the MATRIX doesn’t everloop and I don’t think it’s actually being responsive. I also run matrix ping from my local computer and it just gives me errors.

Turns out I just needed to install MALOS and reboot. Problem solved!

1 Like

Did you have any issues installing MALOS? I’m having a problem getting it running… any links to help set it up would be much appreciated. Thanks!

… and then what? mine has MALOS running and malos_eye and matrix CLI seems to connect me to their environment, but even matrix ping fails.