[Solved] Matrix Voice micarray installation/configuration problems

Hey guys,
i got a new Matrix Voice with a raspi 3 and followed the installation guid for Matrix Core (for the second time, first time i thought i crashed some config files, so i tried again without changing any config). At the first time i tried the matrix-malos-wakeword and it works well, but the test_micarray.js and arecord commands didn’t.

When i run test_micarray.js i get the following output:

$ node test_micarray.js
Got SIGNAL startComplete
Received Info: ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM mic_channel8
arecord: main:788: audio open error: No such file or directory

recording audioProcess has exited with code = 1
Got SIGNAL pauseComplete
Microphone paused
Got SIGNAL resumeComplete
Microphone resumed
Got SIGNAL stopComplete
Microhphone stopped

With “arecord -D hw:1,0 -r 16000 -f S16_LE /tmp/temp.wav” it tries to record something, but the soundfile includes only a tick.

Configuration:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Dummy [Dummy], device 0: Dummy PCM [Dummy PCM]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7

There is no .asoundrc file.

So my questions:
Did i miss an installation?
Do i have to configure the .asoundrc for myself to make it work?
Is there maybe a bug in test_micarray.js?

Sorry, if that’s stupid. I am new to Linux, ALSA and Matrix Voice, so it may be that I am in some initial troubles. Thanks!

Hi @Marden,

Did you installed the kernel modules?
Can you share the output of :

sudo dpkg -l | grep matrix
sudo lsmod | grep matrix

-Yoel

If you already installed the kernel module. The test_micarray.js should work changing the device in the setup as follows:

In line 65 change mic_channel8 for hw:2,0

...
var micInstance = mic({ 
  device: 'hw:2,0',  
  rate: '16000', 
  channels: '1', 
  debug: true, 
  exitOnSilence: 6 
})
...

Thanks guys for the fast response!
Now it works :slight_smile:

First i forgot the installation of the kernel module (would be good in the installation guide imo). After the installation i got the same output, like in my first post. The change of device made it work. Thanks!

1 Like