[SOLVED] MatrixOS API - Clock example

I try to run your Example Clock which by the way have a typo (missing quotes between yellow)

I have beautiful dots in my terminal but nothing on my Matrix

After some challenging back and forth reading between your ressources (I understand, Alpha style) and several testing here’s my setup :

  • In my matrix-os folder clone
  • I copie my App (created with sudo matrix create [my-app]) in ~/matrix-os/apps/[my-app]
  • To avoid error log* I renamed my app : clock
    *except one: clock.matrix is not the same as config name: monitor
  • In my app folder (~/matrix-os/apps/clock) I run node index.js

I get, from the code in app.js, the os info, cpu and memory in my terminal + dots from calling matrix.led() :
[M]() send -> { os_hostname: 'raspberrypi', os_type: 'Linux', os_platform: 'linux', os_arch: 'arm' } [M]() send -> { cpu: 0.055501302083333336, memory: 0.3226413042493226 } C : ....... . .......

Am I on good track or …not ?

If someone is interested on this point we have constructive exchanges (no final solution yet)
here : GitHub issue #10 and here GitHub issue #11

solved here : GitHub issue #11