[Solved] Mic Array Sample Code

Hi all,

I want to record audio data using matrix creator one. I have already installed the sample app from this link - https://github.com/matrix-io/matrix-creator-hal . I was successful in running the demos.
I also run the following:
https://github.com/matrix-io/matrix-creator-quickstart/wiki/Microphone-Array-Recording-Test

But I am not sure what I am getting as output. And how to show the output and do the record test.

But I am confused which one to use to record sound data. Can you refer me any sample project which may help me in my project?

Hi @faysalhossain2007. The microphone page for the MATRIX Creator can show you how to record audio through ALSA. The page will show you how to install the required packages you need as well as a simple command to record and play an audio file. Let us know if you have any more questions.

I followed that link’s tutorial. But not able to record anything.
All the code were executed succesfully. But when I try to play the audio file it is not playing any sound. I have connected a speaker in my Raspberry pi. Speaker details - https://www.amazon.com/Leadsound-Wireless-Speakers-Portable-Computer/dp/B01MRUE2TB

when I also copied that recording.wav file to my laptop. it is not playing any sound.

Can you use the command below to record a 5-second audio file and share it here? It might also be a good idea to reinstall the required packages, from the microphones page, to ensure everything was installed properly. Let us know if you’re still encountering the same result.

arecord recording.wav -f S16_LE -r 16000 -d 5

Yes Sure.

I have created a recording file. Can you please check it ?
Link- https://drive.google.com/open?id=1UuKgGMrvHrHZxkSobP8524u4dRbWCsmT

Still no luck . Not able to record via matrix creator one. Do I need to use any external microphone?

Hi, did you follow Microphones MATRIX from the beginning? I mean from a fresh flashed SD card with Rapsbian?

Can you also share the output of :

sudo dpkg -l | grep matrix
lsmod | grep matrix
cat /etc/asound.conf

Thanks

Did you get this to worked @faysalhossain2007?

-Yoel