[Solved] Missing segments in multi-channel recordings

I have a problem recording multi-channel audio with the MATRIX Creator. Especially in longer recordings (e.g. 1 hour), random parts of the signal (sometimes segments over one second) are missing. I am using micarray_recorder_direct.cpp from the matrix-creator-hal repository on a raspberry pi 2. I played an audio signal over a speaker (source.wav) and recorded it with the MATRIX creator (recorded.wav).Unfortunately I cannot attach the audio files here, but can send them per mail if necessary.

Hi florian,

The micarray_recorder_direct code is an example code on how to access microphoene data from the mics and save it, but is not a fully design app for recording long audio files. Our advice is to use alsa from another software like arecord. If you are using the Raspbian Stretch with desktop you can also use a software with a visual interface like Audacity.

  • Make sure you have installed the kernel modules. Follow the Option 1: Package Installation step
  • Then use arecord :
    arecord -r 16000 -c 1 -f S16_LE test.wav
  • Or use any other software. In this case make sure you select the hw:2,0 as input device.

Let me know how it goes

Ok thanks for the quick answer! I’ll try that and tell you if it worked with arecord.