[Solved] Raspberry Pi doesn't shutdown, only reboots

Hi guys,

Anyone having issues with the Raspberry Pi not shutting down and only rebooting?? I’ve had to reinstall the OS and have updated to the latest version and installed the HAL components only. Now every time I try and shutdown the pi over ssh or console it just reboots, this is the only issue as far as I can see, everything else works as expected. Also this only occurs when the Creator is attached, the Pi shuts down as normal when it isn’t, quite odd!?

Also, slight change to the way an FPGA bit file is flashed, need to change the ‘matrix_pi’ to ‘matrix_creator’ chain in the command; “sudo xc3sprog -c matrix_pi firmware-0.8/blob/system.bit -p 1”

Just to say it is appreciated all the work you are doing on this!!



Can you share the output you are getting?
I just test it and it worked fine.

Please check the shutdown help
~$ sudo shutdown --help

Hi, the output is the same as yours. It shuts down fine, closes connection etc, but then it reboots and I can log on fine. I have tried sudo halt / shutdown / shutdown now etc and same thing happens every time.
I have just connected it up to an older pi with just Stretch installed and the same thing happens, it only reboots, again it shuts down fine when the Creator is not attached.

I run Raspbian Stretch with Matrix Creator (SN: 1701) (fully updated) and have the same issue.
halt, poweroff, shutdown -h now, shutdown -P now always reboot.
Removing the Creator shows normal functionality.
This issue is new since the firmware support for Zigbee/Zwave.
Devs, please have a look.

thanks for the post
… seems I’m not alone…
despite, that half the year passed.
Any solution?
Which processes should be killed
to avoid perpetual restarts?

Another user reported this here Can't Shutdown - always reboots?

No solution yet.

Same problem here. This issue has been there from the very start (even on Jessie).

Hey everyone, we found why this is happening and discuss a temporary workaround that you can use. See here Can't Shutdown - always reboots?

Let me know if it works for you.