[SOLVED] Run NFC-unstable

Hi!

I installed and tested the NFC module available at: https://github.com/matrix-io/matrix-creator-nfc-unstable-preview . However when installing neard-packages and type “update-rc.d -f neard-explorenfc remove” I get the following warnings:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_emphasized text__ALL = (unset),
LC_PAPER = “es_CO.UTF-8”,
LC_ADDRESS = “es_CO.UTF-8”,
LC_MONETARY = “es_CO.UTF-8”,
LC_NUMERIC = “es_CO.UTF-8”,
LC_TELEPHONE = “es_CO.UTF-8”,
LC_IDENTIFICATION = “es_CO.UTF-8”,
LC_MEASUREMENT = “es_CO.UTF-8”,
LC_TIME = “es_CO.UTF-8”,
LC_NAME = “es_CO.UTF-8”,
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).

What is the best local settings (if I am in Colombia) to run the modules nfc?

Thanks!!

1 Like

If Im correct, this issue not belong to Matrix but your Raspberry Pi. You haven’t setup your locale settings
To do so, via your terminal you do :

  • sudo raspi-config
  • 4 Internationalisation Options
  • change locale
    and select one locale (you can also choose several if you want (example I have: FR - UK - USA)

https://www.raspberrypi.org/documentation/configuration/raspi-config.md
https://www.raspberrypi.org/forums/viewtopic.php?t=19308

2 Likes

Solved!!

To fix the problem did the following:

$ sudo raspi-config

  • 4 Internationalisation Options

  • change locale
    After the two comands:
    $ sudo local-gen
    "This generate locales"
    $ sudo dpkg-reconfigure locales
    "Get an assistant and local are added as: en_US-UTF8 & es_CO-UTF8"

    And ready, NFC packages can be installed without problems

THANKS!