TEMPERATURE sensor is requested by the app, but not active

using the code below, I’m trying to read the temperature sensor value. I’ve also tried this for UV. Neither sensors appear to be active. I’ve enabled SPI, I2C in the raspberry pi config.

Thanks,
-George.


app.js

var options = {
  refresh: 1000, //milliseconds
  timeout: 1000 //milliseconds
};

matrix.init('temperature', options).then(function(data){
  //see below for data formats
  console.log('temperature > ', data)
});

config.yaml

configVersion: 2

description: My Sensor Test
keywords: Sensors
name: mySensorTest
displayName: My Sensor Test

sensors:
  - temperature

The reason why is your just initializing it and getting no data is your missing your data type in your config.yaml.

dataTypes:
  temperature: float

As per your suggestion, I added the snippet to the config.yaml file. The output from temperature is still 0.

I also installed “sensorTest”. All the sensors listed give 0 values (except yaw which is 180).

Do I need to enable a setting on the RaspPi or on the MatrixOne itself to initialize the sensors and get the values?

-George.

I am having this same issue when I run the sensorTest app. None of the sensors are working. The clock app doesn’t work either, my LEDs never turn on.

I have chatted with the team yesterday and send them some logs regarding this issue. I hope it will get fixed soon.