Test_zigbee problem

i tried to run test_zigbee.js


but i have these error

so i tried install node and zmq according to this links:
https://matrix-io.github.io/matrix-documentation/matrix-core/getting-started/javascript-installation/
but i have these error while npm
install zeromq --save

how can i fix this problem? I use raspbian buster

@alireza.r,

Welcome to the community!

Are you using the Pi 4 or some other version?

Can you try npm install zmq --save and see if that helps?

I will test and let you know as well.

Best,
Samreen

thanks, Samreen
I am using raspberry pi 3 model b v1.2

I used :
npm install zmq --save
npm install async--save
npm install lodash--save

then all errors gone and then test_zigbee.js lunched

I have Zigbee switch and I want to connect that with matrix creator
but I can’t find my Zigbee switch by matrix creator.everything is ok by Zigbee gateway, Zigbee switch and home mate application.
i remove my switch in home mate application , turn off the Zigbee gateway , then turn on raspberry and matrix creator and run the test_zigbee.js


Best,
Alireza

@alireza.r,

Looks like it’s registering your device and then having some other issues.

Are you using node version 8.6 as recommended by MATRIX Core?

It could be helpful to try registering the device using this code @Carlos wrote for our zigbee light bulb here.

For our zigbee bulb demo, we use this code to create toggle functions for the bulb once the device is registered.

You could try adding the following code to at the end of the toggleZigbee.js file to see if it successfully toggles your switch every 2 seconds.

setInterval(function(){
  sendAllToggleCommand();
}, 2000);

Let me know how it goes. If it works, you may be able to use the toggleZigbee.js file as a template to create some other functions that help you control your zigbee switch.

Best,
Samreen