The certificate chain uses expired certificate

I am trying to install matrix software and I’m having an issue with certificates being expired. This is happening on two different pies on two different networks so I don’t think the problem is on my end.

$ curl https://s3.amazonaws.com/apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2203  100  2203    0     0   6223      0 --:--:-- --:--:-- --:--:--  6223
OK
$ echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list
deb https://apt.matrix.one/raspbian buster main
$ sudo apt-get update
Ign:1 https://apt.matrix.one/raspbian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Err:3 https://apt.matrix.one/raspbian buster Release                 
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 35.190.26.60 443]
Hit:4 http://archive.raspberrypi.org/debian buster InRelease         
Reading package lists... Done                                        
E: The repository 'https://apt.matrix.one/raspbian buster Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.