Ubuntu Mate Support?


#1

Hello,

i’m trying to install Matrix-Hal on ubuntu mate 16.04 to use it with ROS Kinetic.
i’ve used raspian stertch repo and tried to install matrixio-creator-init

but i get the following error.

The following packages have unmet dependencies:
matrixio-creator-init : Depends: libmatrixio-creator-hal but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

has anyone managed to install HAL libs on ubuntu 16.04?


#2

Hi @ibrahimEssam,

We don’t specifically support Ubuntu Mate with the matrix packages that are in our documentation, but there is a lot of useful code/scripts in our https://github.com/matrix-io to get this working.

All the initial setup to communicate with a MATRIX Creator or Voice board is done by scripts located in https://github.com/matrix-io/matrix-creator-init.

You need to also be able to use the SPI bus from Ubuntu Mate to communicate HAL (https://github.com/matrix-io/matrix-creator-hal) with the board.

These are pretty useful and vague instructions on how to start getting this move to talk to the Creator/Voice boards, but let us know if you need anything else.

-Yoel