Unable to deploy any apps

Ive gone through the setup here https://matrix-io.github.io/matrix-documentation/ and tried to the install the sensorTest which failed, then pushed on to the create an app. On matrix deploy command I get the same basic failure. This kill matrix-os until I uninstall the app.
Here is the failure I get after running matrix-os as follows DEBUG=* node index.js any help would be great

sdk Trying to install: testApp +5ms
Stopping testApp
  app Killing process for app testApp +4ms
  app Application Stopped No Longer In activeApplications testApp +2ms
  app Install> { url: 'https://storage.googleapis.com/admobilize-matrix-apps/apps/testApp/5a6b7a397c2f09010013e05f/testapp-92541993.zip',
  name: 'testApp',
  version: '1.0.0',
  id: 'a5d064916191',
  running: false } +4ms
Install App: testApp 1.0.0
  app https://storage.googleapis.com/admobilize-matrix-apps/apps/testApp/5a6b7a397c2f09010013e05f/testapp-92541993.zip +1ms
Uncaught exception:  { Error: read ECONNRESET
    at _errnoException (util.js:1022:11)
    at TLSWrap.onread (net.js:615:25) code: 'ECONNRESET', errno: 'ECONNRESET', syscall: 'read' } Error: read ECONNRESET
    at _errnoException (util.js:1022:11)
    at TLSWrap.onread (net.js:615:25)
UNKNOWN ERROR! Error: read ECONNRESET
    at _errnoException (util.js:1022:11)
    at TLSWrap.onread (net.js:615:25)
  sdk DESTROYING +132ms
Unable to clean, exitting...

This is strange. It seems like connection is failing when trying to download from google.

Can you curl https://storage.googleapis.com/admobilize-matrix-apps/apps/testApp/5a6b7a397c2f09010013e05f/testapp-92541993.zip into the apps folder and unzip it into testApp.matrix subfolder.

Then try to run testApp

Performing that curl call leads to a strange SSL Protocol error

curl --verbose https://storage.googleapis.com/admobilize-matrix-apps/apps/testApp/5a6b7a397c2f09010013e05f/testapp-92541993.zip
*   Trying 172.217.6.80...
* TCP_NODELAY set
* Connected to storage.googleapis.com (172.217.6.80) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: /etc/ssl/certs
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to storage.googleapis.com:443 
* Curl_http_done: called premature == 1
* stopped the pause stream!
* Closing connection 0
curl: (35) Unknown SSL protocol error in connection to storage.googleapis.com:443 

I tried this from both the pi and my workstation…might be a local network issue my end I did throw https://storage.googleapis.com/admobilize-matrix-apps/ into the browser and it resolved ok but curl still barfs in the same way

thanks

Jeff

Ok so it seems like the network at work is blocking access to the google storage requests because everything seems to work on my home network.

Sorry for the time waste.

Jeff

1 Like