Upgrade to 0.1.8 failed

Hi everybody,

my setup was working as far as matrix is regarded. However I ran an apt upgrade and it tried to install the last version of matrixio-kernel-modules from 0.1.7 to 0.1.8. That failed and I couldn’t restore it in any way.

I purged the package as well as the raspberrypi-kernel-headers. Ran apt upgrade and there were - as expected - no more available packages. Then tried the matrix installation again, but it seems to fail for the same reason as the original update.

Does anybody have an idea?

pi@raspberrypi10:~ $ sudo apt install matrixio-kernel-modules
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  dkms raspberrypi-kernel-headers
Suggested packages:
  python3-apport menu
The following NEW packages will be installed:
  dkms matrixio-kernel-modules raspberrypi-kernel-headers
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 16.7 MB/16.8 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-kerne
Fetched 16.7 MB in 12s (1,381 kB/s)
Selecting previously unselected package dkms.
(Reading database ... 46082 files and directories currently installed.)
Preparing to unpack .../archives/dkms_2.3-2_all.deb ...
Unpacking dkms (2.3-2) ...
Selecting previously unselected package raspberrypi-kernel-headers.
Preparing to unpack .../raspberrypi-kernel-headers_1.20190517-1_armhf.deb ...
Unpacking raspberrypi-kernel-headers (1.20190517-1) ...
Selecting previously unselected package matrixio-kernel-modules.
Preparing to unpack .../matrixio-kernel-modules_0.1.8_armhf.deb ...
Unpacking matrixio-kernel-modules (0.1.8) ...
Setting up raspberrypi-kernel-headers (1.20190517-1) ...
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.42+
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.42-v7+
Setting up dkms (2.3-2) ...
Setting up matrixio-kernel-modules (0.1.8) ...
Enabling firmware loading at startup

Creating symlink /var/lib/dkms/matrixio/0.1/source ->
             /usr/src/matrixio-0.1

DKMS: add completed.
Error! echo
Your kernel headers for kernel 4.19.56-v7+ cannot be found at
/lib/modules/4.19.56-v7+/build or /lib/modules/4.19.56-v7+/source.
dpkg: error processing package matrixio-kernel-modules (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 matrixio-kernel-modules
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi10:~ $

What version of raspbian are you using?

cat /etc/debian_version
9.9

Have you already looked at the workaround we created? Kernel Modules 4.19 Workaround.

Hey @jarvis,

The above workaround is not necessary, as we updated our packages to support Linux kernels 4.19.

If you are using Raspbian Stretch, the latest MATRIX kernel modules will not work for you. Version 0.1.8 was updated for Raspbian Buster.

I recommend purging the MATRIX kernel modules from your system, and installing kernel module version 0.1.7. Then, putting the MATRIX kernel module upgrades on hold.

Please follow the commands below.

If you have not already added the MATRIX repo and key

curl https://apt.matrix.one/doc/apt-key.gpg | sudo apt-key add -
echo "deb https://apt.matrix.one/raspbian $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/matrixlabs.list

Then, one by one in your terminal.

sudo apt purge matrixio-kernel-modules

sudo reboot

sudo apt install matrixio-kernel-modules=0.1.7

sudo reboot

sudo apt-mark hold matrixio-kernel-modules

sudo reboot

If you would like to try Raspbian Buster, we partially support it now, but it is still in the testing phase. The following packages have been updated in beta versions for Buster.

Snips is currently having issues, so we’re waiting on Snips updates for that, and some other third party services may not work as well.

Let me know how this goes for you!

Best,
Samreen

Hi @Samreen,

thanks for that. I was a little premature to upgrade my system to buster after reading the first lines of your post. The upgrade went through as far as other packages are concerned.
After changing the apt sources file of matrix it also upgraded 2 other packages, but the matrix-kernel-modules package still fails with the exact same error message as on stretch (after having purged it before of course).

I can also not install 0.1.7 with the above command (as I could not specifically install 0.1.6 a couple of days ago).

For whom it interests: After waiting for further OS updates installing the matrix packages finally worked.

And as far as my audio feedback problem goes: For the most part is was about the bit rate of the audio device. See https://forum.snips.ai/t/snips-not-working-due-to-problems-with-audio-output/3191/7 for more info.

1 Like