Zigbee and z-wave at the same time

It seems like it’s either one or the other because the both use ttyS0. Am I right on that?

as far as i know only one is possible at a time, as the fpga only routes either the zigbee or zwave chip to the serial port of the rpi. maybe there will be an other solution in future to route the zwave and zigbee to different ports on the rpi, but i don’t know if this is possible.

Damn I was hoping to use it control both types of switches

Hello @vizonyc! I did a new release to allows this feature :slight_smile:. Let us prepare a recipe in order to show you an example of this feature :slight_smile:.

Now the Zwave Connection is between ttyMATRIX0: Check how configure your Zwave chip here: https://github.com/matrix-io/matrix-malos-zwave/tree/master/src/js_test

Regards,

Kevin Patino

So right now for testing zigbee I am using this First ZigBee tests with python (bellows) forming a network controller also, I am starting using snips as far as I understand I am using this with just hal will all this still work with malos particularly snips. in the end I wanted to use mqtt and node-red for home control system

I just got zwave working on ttyMATRIX0 does this mean I can run zigbee on ttyS0?

Correct @vizonyc, let us know how it goes

Testing… using bellows and libzwavezip reference_client at the same time and the worked simultaneously.
WoooHooo! now If I can start sending this to mqtt it would be a good controller for the plethora of Home automation systems out there. I really need to learn how to code…

1 Like

Nice, I have to try bellows !

do you do any coding?

Yes, a bit :slight_smile:

(completing 20 caracters min requirement )

do you have mqtt setup ? I am trying to get this to work since i dont know enough to get bellows to mqtt I have been trying to get this to work https://github.com/valorekhov/node-ezsp-mqtt it seem to work but the join doesnt do anything

oh I got it to add a node

zbmq/000d6f000d07ad71/00178801029342d1/response 
{
	“messageType”:4,
	“apsFrame”:{
		“profileId”:0,
		“clusterId”:19,
		“sourceEndpoint”:0,
		“destinationEndpoint”:0,
		“options”:0,
		“groupId”:0,
		“sequence”:150
	},
	“lqi”:249,
	“rssi”:-40,
	“sender”:52195,
	“bindingIndex”:255,
	“addressIndex”:255,
	“message”:{
	 	“type”:“Buffer”,
	 	“data”:[0,227,203,209,66,147,2,1,136,23,0,142]
 	}
}
1 Like