ZWave installation issues on Creator

I’ve been trying to use my Matrix Creator as a ZWave hub and I’m having trouble getting started. I’ve followed all of the instructions I could find to get my firmware etc up to date but still have problems.

First of all running sudo zwave_conf hangs up right after:

#Zwave NVR has been programmed !!! 
INFO: [/dev/matrixio_regmap] was opened
#ZM5202 Response: 53 : AA

and never completes. Any ideas what could cause this?

If I look in /tmp/zipgateway.log I see:

10621 Opening config file /usr/local/etc/zipgateway.cfg
Starting Contiki
Opening eeprom file /usr/local/var/lib/zipgateway/eeprom.dat
Lan device tap0
LAN HW addr F6:0B:08:41:31:DD
10708 Starting zipgateway ver2_61 build ver2_61
10708 Resetting ZIP Gateway
10722 Using serial port /dev/ttyMATRIX0
 SerialAPI: Retransmission 0 of 0x07
 SerialAPI: Retransmission 1 of 0x07
 SerialAPI: Retransmission 2 of 0x07
 SerialAPI: Retransmission 3 of 0x07
 SerialAPI: Retransmission 4 of 0x07
 SerialAPI: Retransmission 5 of 0x07
 SerialAPI: Retransmission 6 of 0x07
 SerialAPI: Retransmission 7 of 0x07
 SerialAPI: Reopening serial port
 SerialAPI: Retransmission 8 of 0x07
 SerialAPI: Retransmission 9 of 0x07
 SerialAPI: Retransmission 10 of 0x07
 SerialAPI: Retransmission 11 of 0x07
 SerialAPI: Retransmission 12 of 0x07
 SerialAPI: Retransmission 13 of 0x07
 SerialAPI: Retransmission 14 of 0x07
 SerialAPI: Retransmission 15 of 0x07
 SerialAPI: Reopening serial port
 SerialAPI: Retransmission 16 of 0x07
 SerialAPI: Retransmission 17 of 0x07
 SerialAPI: Retransmission 18 of 0x07
 SerialAPI: Retransmission 19 of 0x07
 SerialAPI: Unable to send frame!!!!!!
 SerialAPI: SendFrameWithResponse() returning failure
 SerialAPI: SendFrameWithResponse(FUNC_ID_SERIAL_API_GET_CAPABILITIES,...) failed in SerialAPI_Init()
 SerialAPI: Assertion failed at /drone/src/src/serialapi/Serialapi.c:435
59940 Error opening serial API
59940 Fatal error

So… My Matrix Creator DOESN’T have the ZWave approval decal on the bottom. IS that bad? No one told me this one wasn’t compatible when I bought it. Is there any upgrade available???

Hey @stwfstwf,

ZWave on your MATRIX Creator should still work! We are currently having some kernel issues related to ZWave that we are in the process of resolving.

We will let you know once we have an update. Thank you for your patience!

Best,
Samreen