Zwave reference_listener not working with Matrix Creator

Hey,
I added my z wave remote(Aeotec WallMote Quad) by the following steps

$ cd libzwaveip/build/
$ ./reference_client -s fd00:aaaa::3  
$ addnode

The device got added and when I run “list” command inside reference_client I get the following

---   zwE46E422B2D.local: "Wall Controller [e46e422b2d04]"
---   zwE46E422B2D.local: "Wall Controller [e46e422b2d03]"
---   zwE46E422B2D.local: "Wall Controller [e46e422b2d02]"
---   zwE46E422B2D.local: "Wall Controller [e46e422b2d01]"
---   zwE46E422B01.local: "Static Controller [e46e422b0100]"

So it got added.

Now I want to get the Input from this remote in raspberry

When I do the following

$ cd libzwaveip/build/
$ ./reference_listener -l fd00:aaaa::1234

I get this output

PSK not configured - using default
Listening on fd00:aaaa::1234 port 41230

Nothing gets displayed when I press the remote

my /usr/local/etc/zipgateway.cfg is as follows

ZipUnsolicitedDestinationIp6 = fd00:aaaa::1234
ZipUnsolicitedDestinationPort = 41230
#ZipUnsolicitedDestination2Ip6 = fd00:aaaa::0010
#ZipUnsolicitedDestination2Port = 41231
#SerialLog = /tmp/ziprouter.serlog
ZipCaCert=/usr/local/etc/Portal.ca_x509.pem
ZipCert=/usr/local/etc/ZIPR.x509_1024.pem
ZipPrivKey=/usr/local/etc/ZIPR.key_1024.pem
#Eepromfile=/etc/eeprom.dat
#TunScript=/usr/local/etc/zipgateway.tun
ZipLanGw6 = fd00:aaaa::1234
#ZipPortal=192.168.1.1
#ZipPortalPort=44123
#ZipTunPrefix = 2000::
#ZipTunIp6PrefixLength = 128
#ZipManufacturerID=0
#ZipHardwareVersion=1
#ZipProductID=1
#ZipProductType=1
#ZipMBPort=41230
#ZipMBDestinationIp6=
#ZipMBMode=1
ZipPSK=123456789012345678901234567890AA
#ExtraClasses= 0x43 0x75
ZipSerialAPIPortName=/dev/ttyS0
ZipLanIp6=fd00:aaaa::3
ZipPanIp6=fd00:bbbb::1

How to use the reference_listener ?

Hello,

i have an other error:

(ZIP) list
List of discovered Z/IP services:
— zwC600C76901.local: “Static Controller [c600c7690100]”
(ZIP) addnode
AppCmdHdlr: 34020007000001
cmd_class: COMMAND_CLASS_NETWORK_MANAGEMENT_INCLUSION v2
cmd: NODE_ADD_STATUS
Seq. No >
00
Status >
NODE_ADD_STATUS_FAILED
Reserved >
00
New Node ID >
00
Node Info Length >
01
bytestream: 34 02 00 07 00 00 01
Inclusion done

My zipgateway.log:

2792020 nm_fsm_post_event event: NM_EV_FRAME_RECEIVED state: NM_IDLE
2792021 NetworkManagementCommandHandler 34 1
2792047 nm_fsm_post_event event: NM_EV_NODE_ADD_S2 state: NM_IDLE
2792078 nm_fsm_post_event event: NM_EV_ADD_LEARN_READY state: NM_WAITING_FOR_ADD
2822683 Sending keep alive ACK to port:36040 of IP:fd00:aaaa::7b4b:5df0:e245:9ba5
tcpip_ipv6_output: nbr cache entry stale moving to delay
tcpip_ipv6_output: nbr cache entry stale moving to delay
2852049 nm_fsm_post_event event: NM_EV_TIMEOUT state: NM_WAITING_FOR_ADD
2852054 Sending network management reply
tcpip_ipv6_output: nbr cache entry stale moving to delay
2852129 nm_fsm_post_event event: NM_EV_ADD_NODE_STATUS_DONE state: NM_IDLE
2882713 Sending keep alive ACK to port:36040 of IP:fd00:aaaa::7b4b:5df0:e245:9ba5
tcpip_ipv6_output: nbr cache entry stale moving to delay
tcpip_ipv6_output: nbr cache entry stale moving to delay
2908509 DTLS: DTLS read failed
lipaddr: fd00:aaaa::0003 lport: 41230
ripaddr: fd00:aaaa::7b4b:5df0:e245:9ba5 rport: 51340
2908509
tcpip_ipv6_output: nbr cache entry stale moving to delay
2908510 DTLS: Closing DTLS connection
lipaddr: fd00:aaaa::0003 lport: 41230
ripaddr: fd00:aaaa::7b4b:5df0:e245:9ba5 rport: 51340
2908510

Any idea ?

Thanks

Regards,

Eric

A network problem? I configured wired network interface.

br-lan: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.4 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fd00:aaaa::7b4b:5df0:e245:9ba5 prefixlen 64 scopeid 0x0
inet6 fe80::aec7:e98f:3c36:e2c9 prefixlen 64 scopeid 0x20
ether 76:5f:81:aa:5a:7b txqueuelen 1000 (Ethernet)
RX packets 376 bytes 44254 (43.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 316 bytes 46204 (45.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 169.254.187.75 netmask 255.255.0.0 broadcast 169.254.255.255
ether b8:27:eb:3f:83:cc txqueuelen 1000 (Ethernet)
RX packets 326 bytes 33686 (32.8 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 464 bytes 69384 (67.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 2 bytes 78 (78.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2 bytes 78 (78.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 169.254.14.130 netmask 255.255.0.0 broadcast 169.254.255.255
inet6 fe80::97af:4d7f:eff7:7b43 prefixlen 64 scopeid 0x20
inet6 fd00:aaaa::2664:7228:a644:8516 prefixlen 64 scopeid 0x0
ether 76:5f:81:aa:5a:7b txqueuelen 1000 (Ethernet)
RX packets 70 bytes 17612 (17.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 227 bytes 25994 (25.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:6a:d6:99 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0